DT Blog

catch-img

VRFとは?設定例も合わせてわかりやすく解説します

はじめまして!
クレスコ・デジタルテクノロジーズ ストラテジックマーケティングオフィスの井上です!

今回は “ VRFとは?設定例も合わせてわかりやすく解説します ” と題し、『VRF(Virtual Routing and Forwarding) 』について、「VRF って、そもそもなに?」というところから、「簡単な設定例(Cisco 機器 )」も交えながらお伝えできればと思います。


目次[非表示]

  1. 1.VRFって、そもそもなに?
  2. 2.VRFの利用シーンやメリット
  3. 3.機器の設定をしてみよう
  4. 4.さいごに
  5. 5.引用元


VRFって、そもそもなに?

 改めまして、今回は『VRF(Virtual Routing and Forwarding)』をテーマにお伝えします!
といっても、まずは「VRFって?」「どんな機能なの?」というところからざっくりと。

 『VRF』を一言で表すと「1台のルーターの中でたくさんのルーターをばらばらに動かすこと」だと思います。もう少しネットワークの用語を使うと、「1台のルーターが複数の独立したルーティングテーブルをもつこと」とも言えます。普通、1台のルーターには1つのルーティングテーブルしかもてませんよね。ただ、VRFを利用すると、物理的には1台のルーターでも「VRF①」「VRF②」・・・といったように、VRFという論理的な単位でルーターを分離させることができるのです。ハードディスクで例えると「パーティションの分割」、人間で例えると1つの身体にそれぞれ独立した性格をもつ「多重人格」のようなもの、と捉えるとイメージしやすいでしょうか?

 もう少し詳しい説明を続けていきます。
 やはり、最も大きな特徴としては「VRFごとにルーティングテーブルが独立していること」になります。このおかげで、VRFごとのルーティングプロトコル(BGP、OSPFなど)設定や、VRF間でIPアドレスの重複が可能になります。(ただ、VRF間でルーティングをする設計だとアドレス重複してしまうので注意が必要です。)
 また、補足ですが『VRF』には『VRF-Lite』というものがあります。MPLSというラベリング機能の有無によって呼び方が分かれることになりますが、『VRF』という機能としては同じものになっています。設定方法なども同じものになるので、両者の違いについての詳細は割愛させてください。
 ここまで「VRFって、そもそもなに?」について説明をさせてもらいましたが、いかがだったでしょうか?まずは、大まかなイメージだけでもつかんでいただければ十分だと思います!


VRFの利用シーンやメリット

 ここでは、「VRFの利用シーンとそのメリット」をテーマにお伝えさせてください。VRFのメリットも交えながら、今回は3つの利用シーンを紹介します!

① キャリアのIP-VPNサービス
② 社内ネットワーク設計
③ 検証環境

 まず「① キャリアのIP-VPNサービス」としての利用です。実は、大手通信キャリアの法人向けIP-VPNサービスを実現するための技術として、『VRF』の技術が活躍しているのです。お客さんごとにルーティングテーブルが分かれていれば、ルーターの数を抑えつつ、通信の安全性を保つことができます。また、先述したMPLSというラベリング機能を利用し、IPベースでなくラベルベースのルーティングにすることでパケット転送速度の低下を防ぎ、通信品質の低下を防いでいるのです!MPLSについて気になる方は、こちらのサイトを読んでみてください。https://www.infraexpert.com/study/mpls1.html

 次に「② 社内ネットワーク設計」としての利用です。例えば、「複数のグループ会社間で完全にトラフィックを分けたいが、ネットワーク設備は減らしたい」という要望があるときに、『VRF』を使うことで、機器の台数は増やさずにグループ会社それぞれでネットワーク通信を可能にできます。また、グループ会社が増えても「VRFを増やす設定変更」だけで済むので、拡張性にも優れているといえます。

 最後に「③ 検証環境」としての利用についてです。なんといっても、私がVRFを利用したきっかけは社内検証でルーターの台数を減らすためでした。機器の数に限りがある場合には、ルーター1台でいくつものネットワークを構築できる『VRF』の機能は重宝します!一度覚えてしまえば設定も複雑ではないと思うので、おすすめです!

 ここまでで、「VRFの利用シーンとそのメリット」についてお伝えしました。次はいよいよ実際の設定方法についてお伝えします!


機器の設定をしてみよう

 ここまでで、『VRF』についての理解が少しでも深まっていただければ嬉しいです。ここでは、いよいよ具体的な設定例を模擬構成とともにお伝えします!
 早速ですが、設定の流れは以下の通り。

No.1     VRFインスタンスの作成
No.2     ルート識別子の指定
No.3     インターフェースへのVRFインスタンスの適用
No.4     VRFのルーティング設定

 全体の構成図はこちら。(今回はVRFを「SideA」「SideB」の2つ作成します)

 SideAとSideB、同じLANセグメント(192.168.1.0/24)をもつ2つのネットワークを『VRF』を使って1台のルーターに収容し、別々のルーティングテーブルで動かしていきます!
RouterA、RouterBのコンフィグは次の通り。

◆   Router A

RouterA#
RouterA#show running-config
 
hostname RouterA
!
!
interface GigabitEthernet0/0/0
 description # To_VRFRouter #
 ip address 2.2.2.2 255.255.255.252
!
interface GigabitEthernet0/1/0
!
interface Vlan1
 description # LAN_SideA #
 ip address 192.168.1.0 255.255.255.0
!
router bgp 65000
 bgp log-neighbor-changes
 network 192.168.1.0 mask 255.255.255.0
 timers bgp 30 90
 neighbor 2.2.2.1 remote-as 9996
!
end

◆ Router B

RouterB#
RouterB#show running-config
 
hostname RouterB
!
!
interface GigabitEthernet0/0/0
 description # To_VRFRouter #
 ip address 3.3.3.2 255.255.255.252
!
interface GigabitEthernet0/1/0
!
interface Vlan1
 description # LAN_SideB #
 ip address 192.168.1.0 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.1.3.1
!
end

 
では、実際に『VRF』の設定の流れをみていきましょう!

まず、No.1~2で、必要な分だけ「VRFインスタンス」を作成します。

No.1     VRFインスタンスの作成
[VRF名]にはVRFを区別できるように任意の文字列を設定しましょう。

(config)# ip vrf [VRF名]

No.2     ルート識別子の指定
そして、VRF 設定モードでRD (Route Distinguisher) というVRFごとの識別番号を設定します。
このRDは、2つの整数の組み合わせで、VRF 毎に固有の値を設定します。※RDの重複はNGです!

(config-rd)# rd [AS番号]:[任意の整数]


No.3     インターフェースへのVRFインスタンスの適用
次に、必要な分だけ「VRFインスタンス」が作成出来たら、物理L3インターフェースにVRFを適用します。
ここで2点注意点です!
① 設定できるのはL3インターフェースのみ(物理/論理はどちらもOK)!
(スイッチングポートには設定できません!※もししたい場合は、VLANに設定してください)
② 1インターフェースに1VRFまでしか設定できません!
(VRF間でルーティングしたい場合は『VRF間ルーティング』等を使ってください。)
上記の注意点に気を付けて、各インターフェースに「VRFインスタンス」を設定していきます。

(config)#interface [設定したいインターフェース名]
(config-if)#ip vrf forwarding [VRF名]
(config-if)# ip address [IP Address] [Subnet Mask]

※インターフェースにVRFを設定すると既存のIPアドレス設定は自動で削除されてしまいます。


No.4     VRFのルーティング設定
そして、最後にVRFごとにルーティング設定をします。
VRFごとに別々のルーティングテーブルをもつので、VRFごとにルーティング設定が必要になります!

● スタティックルート

Router(config)#ip route vrf [VRF名] [Network Address] [Subnet Mask] [Next-Hop]

● 動的ルーティング(今回は例としてBGPの設定をしてみます)

(config)# router bgp [任意のAS番号]
(config-router)#address-family ipv4 vrf [VRF名]
(config-router-af)#network [Network Address] mask [Subnet Mask]
(config-router-af)#timers bgp [keepalive] [holdtime]
(config-router-af)#neighbor [IP Address] remote-as [Remote AS]
(config-router-af)#neighbor [IP Address] activate
(config-router-af)#exit-address-family


ここまでで、全体のVRF設定はOKです!
検証図の構成では、VRF:SideAではBGPを、VRF:SideBではスタティックルートを設定しています。
VRFRouterの設定は次の通り。


◆   VRF Router

VRFRouter#
VRFRouter#show running-config
 
hostname VRFRouter
!
ip vrf SideA
 rd 100:2
!
ip vrf SideB
 rd 100:3
!
interface GigabitEthernet0/0/0
 description # To_RouterA #
 ip vrf forwarding SideA
 ip address 2.2.2.1 255.255.255.252
!
interface GigabitEthernet0/0/1
 description # To_RouterB #
 ip vrf forwarding SideB
 ip address 3.3.3.1 255.255.255.252
!
interface GigabitEthernet0/1/0
 switchport access vlan 2
!
interface GigabitEthernet0/1/1
 switchport access vlan 3
!
interface Vlan1
 no ip address
!
interface Vlan2
 description # LAN_SideA #
 ip address 192.168.2.0 255.255.255.0
!
interface Vlan3
 description # LAN_SideB #
 ip address 192.168.3.0 255.255.255.0
!
router bgp 9996
 bgp log-neighbor-changes
address-family ipv4 vrf SideA
 network 192.168.1.0 mask 255.255.255.0
 timers bgp 30 90
 neighbor 2.2.2.2 remote-as 65000
 neighbor 2.2.2.2 activate
 exit-address-family
!
ip route vrf forwarding SideB 192.168.1.0 255.255.255.0 3.3.3.2
!
end


最後に、VRFに関する各種コマンドの紹介です。
VRFを設定している機器では、各コマンド入力時に「VRFインスタンス」を指定することになります。

 ● ルーティングテーブルの表示

#show ip route vrf [VRF名]

指定した「VRFインスタンス」のルーティングテーブルを表示します。
 
●   ping/tracerouteの実行

#ping vrf [VRF名] [宛先IP Address]
#traceroute vrf [VRF名] [宛先IP Address]

指定した「VRFインスタンス」のルーティングテーブルに基づいて疎通確認を行います。
 
●   VRFの状態確認

#show ip vrf
#show ip vrf detail

「VRFインスタンス」のRDや設定されているインターフェースを確認することができます。


少し長くなってしまいましたが、いかがだったでしょうか?設定のイメージはもてたでしょうか?
考え方に慣れるまでは少し苦労するかもしれませんが、『VRF』はとても便利な機能なので、触れたことがない方は、まずは一度機器を触って設定してみてほしいと思います!



さいごに

 今回は “ VRFとは?設定例も合わせてわかりやすく解説します ” と題して、「VRFって、そもそもなに?」というところから実際の利用シーン、設定の流れまでお伝えさせていただきました。1つの技術の概要だけでもここまでのボリュームがあるネットワークの世界、おもしろいと思っていただければ何よりです。
 ここまでお読みいただき、ありがとうございました!次回以降のブログでも、ネットワーク、セキュリティ、クラウド、ソフトウェア、サーバーなどなど、幅広く深い内容をご紹介できると思うので、お楽しみに~!


引用元

https://www.infraexpert.com/study/mpls1.html​​​​​​​

井上
井上
部署:ストラテジックマーケティングオフィス

おすすめ資料はこちら

ネットワークテクノロジー

厳しい条件に縛られがちなネットワークのあり方に多角的な視点から最適解を提示します。
クラウドサービスやスマートデバイスの有効活用はもとより、「通話・会議・共有」といったコミュニケーション基盤の導入など、各システムに最適なネットワーク環境をご提案。
より高度化するIT利用に対応します。

CONTACT

社内システムのお悩みを私たちだけで解決へと導きます

ご不明な点はお気軽に
お問い合わせください

お役立ち資料は
こちらから

おすすめ資料

ネットワークテクノロジー

メルマガ登録

人気記事ランキング

タグ一覧